Resolved
This incident has been resolved. Inbound message delivery and outbound message timeouts have returned to normal, and all systems are operating as expected. Thank you for your patience.
Investigating
We are currently investigating reports of slow inbound messages and delivery timeouts on outbound messages. Our team is actively investigating the issue and we will provide an update as soon as we have more information.