Maintenance
Networking: Primary ISP Emergency Maintenance
Completed .
Completed
The emergency maintenance has concluded. There was no disruption in Linq Services and all operating as normal throughout.
Updated
The emergency maintenance at our primary ISP is still ongoing at this time. All Linq Services are continuing to operate without interruption or degradation. We will continue to monitor and update when the ISP concludes the Emergency Maintenance.
Updated
Two of our Three terminals have seen primary ISP outages and failed over successfully to our secondary providers. We are not seeing any increased latency currently. The third terminal is still awaiting outages from the ISP maintenance. We're continuing to monitor our services and will continue to update.
Started
We're scheduling Linq Maintenance for an upcoming emergency maintenance window scheduled by our upstream fiber provider, that may affect Linq services. The maintenance is expected to take place over a 60-minute period, though it could extend throughout the full window depending on the nature of the work. Linq has failover configurations in place for our internet providers. We do not anticipate a full service outage; however, you may experience increased network latencies during this window while traffic is rerouted across redundant paths.
📅 Maintenance Window
UTC: April 1, 2026 - 04:00 AM to 07:00 AM UTC
Central: March 31, 2026 - 11:00 PM to 2:00 AM CDT
Pacific: March 31, 2026 - 9:00 PM to Midnight PDT
Our team will be monitoring the situation throughout the maintenance window and is prepared to respond to any issues that arise.
If you have any questions or concerns, please don't hesitate to reach out. We'll follow up with a post-maintenance confirmation once the fiber provider gives us the all clear.