Get in touch
Back
Resolved

Service disruption due to AWS outage

Started 20 Oct at 05:58am HDT, resolved 20 Oct at 07:33pm HDT.

Platform API Web & Mobile Apps Linq Phone Linq Blue Linq Blue API
Resolved

All systems fully recovered; working on root cause prevention.

Posted 20 Oct at 07:33pm HDT.
Updated

Processing queues have cleared up, and message flow is moving faster across the platform.

We’re still implementing a long-term fix to address the root cause, and during that work, some delays may continue intermittently.

We’ll post another update once the fix is fully deployed and performance stabilizes.

Posted 20 Oct at 06:34pm HDT.
Re-appeared

We’re currently seeing delayed processing across parts of the platform. Some messages and requests may take longer than usual to complete.

Our team is investigating and monitoring system performance closely. We’ll share another update as soon as processing times return to normal.

Posted 20 Oct at 05:37pm HDT.
Resolved

All systems have remained stable, and message delivery across Linq Blue and the Platform API is fully operational.

We’re marking this incident as resolved, but we’ll continue to keep a close eye on system performance to ensure no new issues arise.

Thank you for your patience throughout today’s outage.

Posted 20 Oct at 04:54pm HDT.
Updated

We’ve successfully redeployed all instances, and all are now reporting healthy. System performance has largely returned to normal, and message delivery is functioning as expected.

While things appear stable, we’re continuing to monitor closely to ensure there’s no regression or lingering instability.

Any messages received during the downtime should now sync correctly into Linq Blue as systems continue processing queued inbound traffic.

Posted 20 Oct at 03:18pm HDT.
Updated

We’ve seen some instances deploy successfully, and parts of the platform are beginning to recover. However, we’re not yet seeing full restoration across all systems.

Some requests and message sends are now succeeding, while others may still fail intermittently.

We’re continuing to work toward full recovery and will share another update as progress continues.

Posted 20 Oct at 03:05pm HDT.
Updated

We’re currently experiencing a major disruption across our systems. Most services are failing due to our inability to spin up new instances, and several existing instances are in a degraded state.

Our team is actively working to restore capacity and stability as quickly as possible. We’ll continue to provide updates as we make progress.

Posted 20 Oct at 02:09pm HDT.
Updated

We’re currently seeing increased error rates across parts of our platform and are investigating the cause.

Some Linq Blue message sends and API requests may be failing or delayed. We’ll share another update as soon as we have more information.

Posted 20 Oct at 01:49pm HDT.
Updated

Our systems are largely stable, but we’re still seeing some intermittent issues due to a few backend instances remaining in a degraded state following the AWS outage.

This can cause certain requests to fail randomly, depending on which server they’re routed to. As a result, some inbound Linq Blue messages may still experience short delays before being picked up and processed.

We’re continuing to monitor closely and are working to ensure all instances are fully healthy before closing this incident.

Posted 20 Oct at 01:08pm HDT.
Updated

Our systems have returned to normal operation, and message delivery across Linq Blue and the Platform API is performing as expected.

We haven’t yet received an official all-clear from AWS, so we’ll keep this incident open while we monitor to ensure stability and confirm there’s no regression.

We’ll post a final update once AWS confirms full resolution.

Posted 20 Oct at 12:41pm HDT.
Updated

We continue to see health metrics trending in the right direction, and most services are coming back online.

Linq Blue message delivery and Platform API performance have both improved significantly. We’ll continue to monitor closely to ensure all systems return to a fully healthy state before marking this incident resolved.

Posted 20 Oct at 11:40am HDT.
Updated

We’re starting to see signs of recovery across our systems as AWS services stabilize. Linq Blue message delivery and API performance are gradually improving.

That said, we’re still observing some intermittent errors and delays, so we’re not marking this incident as fully resolved yet.

We’ll continue to monitor closely and post another update once we’re confident services have fully recovered.

Posted 20 Oct at 10:13am HDT.
Updated

We’re still waiting on updates from AWS regarding their ongoing outage. Our platform remains unstable, and outbound Linq Blue messages are still not sending successfully.

Inbound messages to Linq Blue numbers are syncing inconsistently and may be delayed longer than usual while systems recover.

We’re continuing to monitor closely and will update as soon as AWS provides more information or stability returns.

Posted 20 Oct at 08:49am HDT.
Updated

We’re now seeing intermittent errors in our main Platform API as well, related to the ongoing AWS outage impacting Linq Blue.

We’re continuing to monitor closely and will post updates as conditions change.

Posted 20 Oct at 08:30am HDT.
Updated

Most Linq Blue Message sends continue to fail, and inbound messages are syncing with delays.

There have been no new updates from AWS or other affected infrastructure providers at this time. We’re continuing to monitor their status and will update as soon as recovery efforts begin.

You can track AWS’s latest updates here: https://health.aws.amazon.com/health/status

Posted 20 Oct at 07:25am HDT.
Updated

The AWS outage continues to impact Linq Blue message delivery. Most message sends are still failing, and inbound messages are syncing but remain delayed.

You can follow AWS’s own service status here: https://health.aws.amazon.com/health/status

We’re continuing to monitor the situation and will update as soon as AWS recovery efforts begin to stabilize services.

Posted 20 Oct at 06:52am HDT.
Updated

We’re currently seeing most Linq Blue message sends fail due to the ongoing AWS infrastructure outage.

Inbound messages are syncing successfully but with longer-than-usual delays.

Our team is continuing to monitor the situation with AWS and will post updates as recovery progresses.

Posted 20 Oct at 06:16am HDT.
Updated

During this time, attempts to send messages may fail or take longer than usual. Any incoming messages received while systems are degraded will still sync correctly into Linq Blue once service stabilizes, though delivery may be delayed.

We’re monitoring AWS recovery progress and will post another update as soon as performance improves.

Posted 20 Oct at 06:04am HDT.
Created

We’re currently experiencing degraded performance and intermittent errors within Linq Blue due to an ongoing AWS infrastructure outage. This issue is impacting message delivery and related API requests for some users.

Our team is monitoring AWS’ recovery progress and making adjustments to minimize disruption. We’ll post another update once service stability improves.

Posted 20 Oct at 05:58am HDT.